1.5 Template Project

The Joomla! Documentation Working Group is running a project to develop detailed reference and tutorial material on Joomla! 1.5 templates.  There is a project page on the documentation wiki where you can see the work in progress and help us by contributing your knowledge.

Who's Online

We have 10 guests online

Help Site License

The Joomla! Help Site content is copyright © 2005 - 2008 by the individual contributors and can be used in accordance with the Creative Commons License, Attribution NonCommercial ShareAlike 2.5. Some parts of this website may be subject to other licenses.
Home arrow Installation Manual arrow Obtaining Joomla!

PDF Print E-mail

Minimum System Requirements

To successfully install and use Joomla! you must have a fully operational web server (Apache or IIS), a database (MySQL is the optimum) and the server side scripting language PHP together with specific modules that are activated within PHP for MySQL, XML, and Zlib functionality amongst others.
Whilst the community will always do its best to help you resolve issues that you may experience, Joomla! is not a web server in its own right and depends on you having a fully functioning & compatible Web server. 

Joomla! is developed and tested primarily on the Apache web server versions 1.3.x + and 2.x +.
As of Joomla! 1.5.16 Microsoft IIS is also supported. It will also run on many other servers. 
For database MySQL is the principle choice but other types of database may work with the necessary configuration but are less well supported at the present time. This is a situation that it is hoped will be turned around with time but for this to happen the community requires people with the appropriate skills to step forward and assist.

The minimum versions of the various constituent parts of these server components that are required are as follows:


Software Min Requirement Recommended Latest Options Web Site
PHP 4.3.10 4.4.7 5.x series http//php.net
MySQL 3.23.x or above   5.x series http://dev.mysql.com/downloads/mysql/5.0.html
Apache 1.3 or above   2.2 series http://httpd.apache.org
IIS  6  7  7.5 http://www.iis.net/
mod_mysql        
mod_xml        
mod_zlib        

 

You must ensure that you have the MySQL, XML, and Zlib functionality enabled within your PHP installation. This is controlled within the php.ini file.

Do not use PHP 4.3.9, PHP 4.4.2 or PHP 5.0.4; these releases have known bugs that will interfere with the installation of Joomla! There was also an issue with the Zend Optimizer Version 2.5.10 for PHP 4.4.x. You should ask your host to upgrade to a later release as soon as possible where applicable.
If you experience problems with Joomla! on other versions of these source server programs please take the time to check out the changelogs for your particular version, as there are often good indicators of the likely cause of issues. If there is a particular problem identified you need to notify your Host provider and encourage them to update the affected program

MySQL 6.x is not yet supported. 

There are currently ongoing discussions as to whether there are additional issues with the whole 4.3.x. series of releases of PHP. It has been found that the best and most consistent results are achieved with the PHP 5.x series. 

Joomla! has been successfully tested on many variants within the main three OS for Windows, Linux, Apple Mac OSX. It may well work on other platforms but this is less well documented.

Joomla! is also regularly used and tested through the main web browsers available such as IE6 +, Firefox 1.5 +, Safari, and Opera but it may also work with others.

There have been known issues with IE6 and certain CSS display settings in template presentation and this should be borne in mind.

Last Updated ( Monday, 26 April 2010 )
 
< Prev   Next >