1.5 Template Project

The Joomla! Documentation Working Group is running a project to develop detailed reference and tutorial material on Joomla! 1.5 templates.  There is a project page on the documentation wiki where you can see the work in progress and help us by contributing your knowledge.

Who's Online

We have 4 guests online

Help Site License

The Joomla! Help Site content is copyright © 2005 - 2008 by the individual contributors and can be used in accordance with the Creative Commons License, Attribution NonCommercial ShareAlike 2.5. Some parts of this website may be subject to other licenses.
Home arrow Help Screens arrow Help Screens :: Menu arrow Menu Item: Link - Component Item

Menu Item: Link - Component Item PDF Print E-mail

1012_doc_icon

Type:

com_menus - add (or edit)

Access:

menu=>Menu=>Menu Manager=>Menu Manager [ menuname ] - New (or Edit)

menu=>Menu=>Menu Manager [ menuname ] - New (or Edit)

Quick Icon=>Menu Manager=>Menu Manager [ menuname ] - New (or Edit)

User Level:

Manager; Administrator; Super Administrator.

Screenshot:

 Menu Item : Link - Component Item

Description:

The Link - Component Item, adds a shortcut to a named Component. The resultant target display page will replicate the Parameter settings of the original Component Menu Item, as defined in the Add Menu Item :: Component.

The Link - Component Item is useful if you want a Component to appear in more than one Menu and  simply want to change the Details  settings for that Component whilst keeping the Parameter settings as defined in the original Menu Item.

One function that is added to the Details settings is the ability to open the new link in an alternative browser window.

Toolbar:

back_save_apply_cancel_help_tb

save_apply_close_help

 New Menu Item Toolbar Edit Menu Item Toolbar

Back: Click Back to return to the previous screen to select a different type of Menu Item to create the new entry from.

Save: Click Save to save any changes made during the current editing session and return to the Menu Manager [ menuname ] screen.

Apply: Click Apply to save any changes made so far in the current editing session but remain in the Edit Menu Item screen to continue editing. Once the editing session is complete click Save as above. If a New Menu Item was being created the screen title switches from New to Edit, and the New Menu Item will have been added to the particular Menu. The Toolbar changes to reflect the change of function and it is no longer possible to select an alternative Menu Item type.

Cancel: Clicking Cancel at any point ends the creation of a New Menu Item and returns the display to the Menu Manager [ menuname ] screen. Any changes made since the session commenced will be lost.

Close: Clicking Close at any point ends the current editing session and returns the display to the Menu Manager [ menuname ] screen. Any changes made since the session commenced, or since the last time Apply was clicked, will be lost.

Help: Click the Help icon at any time to view this Help Screen.

Details:

Name: Enter the name that is required to appear on the Menu to identify this Menu Item.

Component to Link: Select the Component, that a shortcut will be directed to, from the list of available Components. The list shows only those Components to which existing Menu Items have already been created.

URL : The URL will be created automatically by Joomla! when the Apply or Save icons are first clicked. The URL represents the internal link to the display element of the Component itself.

On Click, Open in: Determines where the new target display page will open. Choose from the three available options:

  • Parent Window With Browser Navigation - Opens the Section target page within the current browser window.
  • New Window With Browser Navigation - Opens the Section target page in a new instance of the browser window, with the normal toolbars and menus displayed.
  • New Window Without Browser Navigation - Opens the Section target page in a new instance of the browser window, without the normal toolbars and menus being displayed.

Parent Item : Select the existing Parent Item to which this Menu Item is to be associated. By default this is Top. Top is the Menu itself. The Menu Item will be visible in the normal view of the Menu. If another Menu Item is selected then this Menu Item will become a sub-Menu Item and will not be visible until the Parent is clicked.

Ordering: Control where this Menu Item will appear in its Menu, in the Front-end. Select this position from the drop-down display of current Menu Items contained in the Menu.

note711_smallNOTE: By default the new Menu Item is placed at the end of the Menu. Its position can be changed once the New Menu Item has been saved for the first time. The resulting drop down box displays all Menu Items in the Menu whether they are published or not.

Access Level: Define which of the three document Access Levels applies to this Menu Item. Select from Public, Registered, or Special.

Published: Select Yes (the default setting) to Publish this Menu Item in the Menu. This will display the Name of the Menu Item, as entered above, in the Menu.

Parameters:

Menu Image: Select a small image, from the drop down list of available images, to be placed to the left or right of the Menu Item Title in the Menu. Images must be located in joomla_root/images/stories/ directory.

Related Information: 

Menu Manager [ mainmenu ] Trash Manager Content by Section
Menu Manager [ othermenu ] Move Menu Item Category Manager
Menu Manager [ topmenu ] Copy Menu Item Section Manager
Menu Manager [ usermenu ] All Content Items  

note711_small NOTE: If you have any suggestions or comments for this Help Screen, please submit them on the Suggestions, Modifications, and Corrections forum.

Thank You

The User Documentation Team

Last Updated ( Monday, 09 April 2007 )
 
< Prev   Next >